Opened 5 years ago

Closed 4 years ago

#880 closed defect (fixed)

mpich2 depends on python/2.6, python/2.7 installed

Reported by: skylar Owned by: skylar
Priority: major Milestone: 3.4.0
Component: Both Version:
Keywords: Cc:
Blocked By: Blocking:
Estimated Hours: 2 Total Hours: 1.00

Description

need a rebuild

Change History (10)

comment:1 Changed 5 years ago by skylar

  • Status changed from new to assigned

./configure --prefix=/bccd/software/mpich2/3.1.2/Linux/BCCD/x86_64 --enable-threads=multiple

comment:2 Changed 5 years ago by skylar

Actually

  1. <code>module purge && module load modules intelcc</code>
  2. <code>CC=$(which icc) CXX=$(which icc) FC=$(which ifort) ./configure --prefix=/bccd/software/mpich2/3.1.2/Linux/BCCD/x86_64 --enable-threads=multiple</code>
  3. <code>nice make -j3</code>
Last edited 5 years ago by skylar (previous) (diff)

comment:3 Changed 5 years ago by skylar

Last edited 5 years ago by skylar (previous) (diff)

comment:4 Changed 5 years ago by skylar

seems like i686 cannot build - compilation aborted for modeldata.cpp (code 4) /usr/include/features.h(323): catastrophic error: could not open source file "bits/predefs.h"

#include <bits/predefs.h>

comment:6 Changed 5 years ago by skylar

multiarch is some fascinating stuff

CC=icc CXX=icpc FC=ifort ./configure --prefix=/bccd/software/mpich2/3.1.2/Linux/BCCD/x86_64

/var/lib/gems/1.9.1/gems/fpm-1.2.0/bin/fpm -n mpich2 -v 3.1.2 -a amd64 -s dir -t deb ${BCCD_SW}/mpich2/3.1.2/${ARCHPATH}

OR

/var/lib/gems/1.9.1/gems/fpm-1.2.0/bin/fpm -n mpich2 -v 3.1.2 -a i386 -s dir -t deb ${BCCD_SW}/mpich2/3.1.2/${ARCHPATH}

comment:7 Changed 5 years ago by skylar

In 4873:

adding mpich2 3.1.2 module file (#880)

comment:8 Changed 5 years ago by skylar

also need to symlink libmpi.so.12 to libmpi.so.1

comment:9 Changed 5 years ago by skylar

also need CPPFLAGS=-I/usr/include/i386-linux-gnu if you get errors about missing predefs.h on i686

comment:10 Changed 4 years ago by skylar

  • Resolution set to fixed
  • Status changed from assigned to closed

mpich2 installed from debian

Note: See TracTickets for help on using tickets.