Opened 6 years ago

Closed 6 years ago

#798 closed defect (fixed)

libGL broken

Reported by: jjhursey@… Owned by: skylar
Priority: minor Milestone: 3.3.1
Component: Both Version:
Keywords: Cc:
Blocked By: Blocking:
Estimated Hours: 4 Total Hours: 1.83

Description

Some updates on my progress...

There are two installations of the libnvidia-tls.so file. One in /usr/lib and the other in /usr/lib/tls. They both point to the libnvidia-tls.so.304.51 file in the respective directory.

These two version of libnvidia-tls.so.304.51 are different. If you move the one in /usr/lib out of the way, and point it to the one in /usr/lib/tls/:

su cd /usr/lib mv libnvidia-tls.so zold_libnvidia-tls.so ln -s /usr/lib/tls/libnvidia-tls.so libnvidia-tls.so mv libnvidia-tls.so.304.51 zold_libnvidia-tls.so.304.51 ln -s /usr/lib/tls/libnvidia-tls.so.304.51 libnvidia-tls.so.304.51

Then glxgears runs, but with a warning from the nvidia driver. So maybe there is something broken in the distro?

mesa-utils should be installing its own version of libGL.* in /usr/lib, but will not override the existing nvidia driver. So I had to manually move the nvidia libGL out of the way:

su cd /usr/lib rm libGL.so ; ln -s libGL.so.1.2 libGL.so rm libGL.so.1 ; ln -s libGL.so.1.2 libGL.so.1

Once I did that then glxgears ran without the warning. Note that you do not need to move the libnvidia-tls.so file if you just do this step (since libGL was the one pulling it into the binary).

This procedure seems non-obvious to me just to get libGL working. I am wondering if anyone else had see this issue before, and if this is an appropriate way to "fix" the problem (or if there is a better way).

Best, Josh

On Fri, Jun 21, 2013 at 1:50 PM, Joshua Hursey <jjhursey@…> wrote:

I installed mesa-utils via aptitude in a freshly liberated LittleFe? machine. However, when I run a command like glxdemo I get a segv.

I attached gdb and found the following stack trace: -------------------- shell$ gdb glxdemo GNU gdb (GDB) 7.0.1-debian Copyright (C) 2009 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Type "show copying" and "show warranty" for details. This GDB was configured as "x86_64-linux-gnu". For bug reporting instructions, please see: <http://www.gnu.org/software/gdb/bugs/>... Reading symbols from /usr/bin/glxdemo...(no debugging symbols found)...done. (gdb) run Starting program: /usr/bin/glxdemo [Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault. 0x00007ffff6d84a06 in _nv015tls () from /usr/lib/libnvidia-tls.so.304.51 (gdb) bt #0 0x00007ffff6d84a06 in _nv015tls () from /usr/lib/libnvidia-tls.so.304.51 #1 0x00007ffff7b66ff0 in ?? () from /usr/lib/libGL.so.1 #2 0x00007ffff7b46c6c in ?? () from /usr/lib/libGL.so.1 #3 0x00007ffff7b47096 in ?? () from /usr/lib/libGL.so.1 #4 0x00007ffff7decc69 in ?? () from /lib64/ld-linux-x86-64.so.2 #5 0x00007ffff7decda7 in ?? () from /lib64/ld-linux-x86-64.so.2 #6 0x00007ffff7ddfb2a in ?? () from /lib64/ld-linux-x86-64.so.2 #7 0x0000000000000001 in ?? () #8 0x00007fffffffe459 in ?? () #9 0x0000000000000000 in ?? () (gdb) --------------------

In dmesg there is a general protection error from the kernel (you can see I tried to run glxinfo before this with the same result): -------------------- shell$ dmesg | tail -n 5 eth1: rxqlen 30 --> 40 eth1: rxqlen 40 --> 44 eth1: rxqlen 43 --> 45 traps: glxinfo[15171] general protection ip:7f986cc56a06 sp:7fff10be5178 error:0 in libnvidia-tls.so.304.51[7f986cc56000+3000] traps: glxdemo[15282] general protection ip:7fd4a68a3a06 sp:7fff42423d88 error:0 in libnvidia-tls.so.304.51[7fd4a68a3000+3000] --------------------

Some information on the system: -------------------- shell$ uname -a Linux node000.bccd.net 3.6.0bccd-00748-g657543a #6 SMP PREEMPT Mon Nov 12 11:23:51 EST 2012 x86_64 GNU/Linux --------------------

Any idea on why the nvidia driver/library is failing here? Or ideas on how to fix the issue?

Thanks, Josh

-- Joshua Hursey Assistant Professor of Computer Science University of Wisconsin-La Crosse http://cs.uwlax.edu/~jjhursey

-- Joshua Hursey Assistant Professor of Computer Science University of Wisconsin-La Crosse http://cs.uwlax.edu/~jjhursey

_ Bccd-users mailing list Bccd-users@… http://bccd.net/cgi-bin/mailman/listinfo/bccd-users

_ bccd-developers mailing list bccd-developers@… http://bccd.net/cgi-bin/mailman/listinfo/bccd-developers

Change History (8)

comment:1 Changed 6 years ago by skylar

  • Owner set to skylar
  • Status changed from new to assigned

comment:2 Changed 6 years ago by skylar

this RH bug report is surprisingly helpful for a RH bug report:

https://bugzilla.redhat.com/show_bug.cgi?id=737223

LD_PRELOAD=/usr/lib/libGL.so.1.2 glxgears

works for me

comment:3 Changed 6 years ago by amweeden06

  • Milestone set to 3.3.1

comment:4 Changed 6 years ago by skylar

  • Status changed from assigned to qa

comment:5 Changed 6 years ago by skylar

In 4553:

adding test for GLX (#798)

comment:6 Changed 6 years ago by skylar

In 4555:

add mesa-utils for glxinfo test (#798)

comment:7 Changed 6 years ago by skylar

In 4557:

merging in test suite updates (#524,#798,#801)

comment:8 Changed 6 years ago by skylar

  • Resolution set to fixed
  • Status changed from qa to closed
Note: See TracTickets for help on using tickets.