Opened 9 years ago

Closed 8 years ago

#598 closed defect (closed)

libgl reports incorrect architecture on amd64

Reported by: fitz Owned by: skylar
Priority: major Milestone: 3.0.3
Component: Both Version:
Keywords: Cc:
Blocked By: Blocking:
Estimated Hours: 2 Total Hours: 5.50

Description

See during bootup. More specifically "wrong ELF class."

GL isn't alone... libjavaplugin_oji.so also reports the same during startup of Firefox.

Change History (30)

comment:1 Changed 9 years ago by skylar

  • Estimated Hours changed from 0 to 2
  • Owner set to skylar
  • Status changed from new to assigned

comment:2 Changed 9 years ago by skylar

In [2954]:

remove java plugin, install with apt (#598)

comment:3 Changed 9 years ago by skylar

1.0 hours logged for skylar: re java, going to try installing sun-java6-plugin rather than supplying a standalone file

comment:4 Changed 9 years ago by skylar

In [2956]:

accept java license non-interactively (#598)

comment:5 Changed 9 years ago by skylar

In [2957]:

putting architecture-specific objects in arch tree (#598)

comment:6 Changed 9 years ago by skylar

0.5 hours logged for skylar: getting build ready for cuda fix/update

comment:7 Changed 9 years ago by skylar

0.5 hours logged for skylar: java works

comment:8 Changed 9 years ago by skylar

tested shodor fire!! on both i386 and amd64, both work

comment:9 Changed 9 years ago by skylar

In [2960]:

moving X11R6 architecture-specific stuff (#598)

comment:10 Changed 9 years ago by skylar

In [2961]:

adding new nvidia support, architecture right now (#598)

comment:11 Changed 9 years ago by skylar

0.5 hours logged for skylar: 32-bit work needs liberation due to problems with linux-headers

comment:12 Changed 9 years ago by skylar

In [2965]:

adding 32-bit nvidia shared objects and headers (#598)

comment:13 Changed 9 years ago by skylar

In [2966]:

fixing symlinks (#598)

comment:14 Changed 9 years ago by skylar

2.0 hours logged for skylar: got nvidia to build properly, testing out

next up is cuda

comment:15 Changed 9 years ago by skylar

In [2968]:

switch cuda 2.3 -> 3.2.16 (#598)

comment:16 Changed 9 years ago by skylar

In [2969]:

new cuda (#598)

comment:17 Changed 9 years ago by skylar

In [2970]:

wrong path (#598)

comment:18 Changed 9 years ago by skylar

0.5 hours logged for skylar: updating cuda, test tomorrow

comment:19 Changed 9 years ago by skylar

In [2971]:

removing broken cuda (#598)

comment:20 Changed 9 years ago by skylar

In [2972]:

cuda w/ lib (#598)

comment:21 Changed 9 years ago by skylar

0.5 hours logged for skylar: cuda successfully updated

comment:22 Changed 9 years ago by fitz

  • Milestone set to 3.0.3

comment:23 Changed 9 years ago by skylar

In [3050]:

merging in #598, #599, #603, #604, #605, #607, #611

comment:19 Changed 9 years ago by skylar

In [3075]:

committing changes for #598, #599, #603, #604, #605, #607, #611

comment:20 Changed 8 years ago by fitz

  • Status changed from assigned to qa

comment:21 Changed 8 years ago by skylar

This should be tested by someone with a modern NVIDIA chipset (i.e. CudaFE)

comment:22 Changed 8 years ago by skylar

In [3101]:

some cuda stuff didn't make it into svn (#598)

comment:23 Changed 8 years ago by fitz

In [3105]:

merge the addition of cuda-stuff in rc-3.0.3 (#598)

comment:24 Changed 8 years ago by skylar

In [3108]:

merging in missing cuda files (#598)

comment:25 Changed 8 years ago by fitz

  • Resolution set to closed
  • Status changed from qa to closed

CUDA source now compiles and links successfully. However, does not run successfully. Closing this ticket since libgl works fine now. #619 should be used for the CUDA not running correctly issue.

Note: See TracTickets for help on using tickets.