Opened 11 years ago

Closed 10 years ago

#481 closed defect (fixed)

Trac errors

Reported by: fitz Owned by: fitz
Priority: minor Milestone:
Component: None Version:
Keywords: Cc:
Blocked By: Blocking:
Estimated Hours: 0 Total Hours: 0

Description (last modified by fitz)

How to Reproduce

While doing a GET operation on /report, Trac issued an internal error.

This happens to me periodically when accessing any Trac page. Need more evidence to see what's happening.

User Agent was: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-US) AppleWebKit/533.2 (KHTML, like Gecko) Chrome/5.0.350.0 Safari/533.2

System Information

Trac 0.11.6
Python 2.5.2 (r252:60911, Apr 27 2008, 17:40:49)
[GCC 4.2.1 20070719 [FreeBSD]]
setuptools 0.6c8
psycopg2 2.0.7
Genshi 0.5.1
mod_python 3.3.1
Pygments 0.11.1
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 176, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 296, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/versioncontrol/api.py", line 86, in pre_process_request
    self.get_repository(req.authname).sync()
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/versioncontrol/api.py", line 132, in get_repository
    for connector in self.connectors
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/core.py", line 70, in extensions
    return filter(None, [component.compmgr[cls] for cls in extensions])
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/core.py", line 207, in __getitem__
    component = cls(self)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/core.py", line 111, in maybe_init
    init(self)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/versioncontrol/svn_fs.py", line 266, in __init__
    Pool()
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/versioncontrol/svn_fs.py", line 156, in __init__
    self._pool = core.svn_pool_create(self._parent_pool())
  File "/usr/local/lib/python2.5/site-packages/svn/core.py", line 241, in svn_pool_create
    return Pool(parent_pool)
  File "/usr/local/lib/python2.5/site-packages/libsvn/core.py", line 1555, in svn_pool_create
    return apply(_core.svn_pool_create, args)
  File "/usr/local/lib/python2.5/site-packages/libsvn/core.py", line 5738, in _wrap
    obj.set_parent_pool(self)
  File "/usr/local/lib/python2.5/site-packages/libsvn/core.py", line 5651, in set_parent_pool
    self._parent_pool = parent_pool or application_pool
  File "/usr/local/lib/python2.5/site-packages/libsvn/core.py", line 5639, in <lambda>
    __setattr__ = lambda self, name, value: _swig_setattr(self, apr_pool_t, name, value)
  File "/usr/local/lib/python2.5/site-packages/libsvn/core.py", line 24, in _swig_setattr
    return _swig_setattr_nondynamic(self,class_type,name,value,0)
  File "/usr/local/lib/python2.5/site-packages/libsvn/core.py", line 19, in _swig_setattr_nondynamic
    self.__dict__[name] = value
RuntimeError: instance.__dict__ not accessible in restricted mode

Change History (5)

comment:1 Changed 11 years ago by fitz

The logs are largely useless for this particular event; hard to say what the problem might be.

comment:2 Changed 10 years ago by fitz

  • Owner set to fitz
  • Status changed from new to assigned

comment:3 Changed 10 years ago by skylar

maybe the update I did today to 0.12 will help

comment:4 Changed 10 years ago by fitz

  • Description modified (diff)

According to http://trac.edgewall.org/wiki/TracSubversion#instance-dict-restricted-mode this is fixed by setting "PythonInterpreter? main_interpreter" in the server config.

comment:5 Changed 10 years ago by fitz

  • Resolution set to fixed
  • Status changed from assigned to closed

Hard to test, but it looks like setting main_interpreter fixes is.

Note: See TracTickets for help on using tickets.