Problems with Calibrating Dissolved Oxygen

From Earlham Cluster Department

Jump to: navigation, search

Problems with Calibration

Calibrating Dissolved Oxygen has been problematic, and has never worked correctly. Instead of displaying a consistent reading, when submerged in a liquid the probe will at first display a value of either 99% Dissolved Oxygen or -99% Dissolved Oxygen, and after a few seconds of sampling, will start jumping wildly, going from -99% to 50% to -37% to 77%, or following another, similar pattern.

The following techniques were used to calibrate Dissolved Oxygen:

Note that none of them have worked correctly.

The Chemistry department has a tank of water through which oxygen is constantly bubbled through, giving the solution a concentration of 100% Dissolved Oxygen or approximately 8 mg/l. The probe was submerged in the solution and calibrated both with Dissolved Oxygen % and Dissolved Oxygen mg/l with the appropriate atmospheric measurements taken.

Filling the calibration chamber slightly with water, then loosening the top of the chamber to allow for the water to evaporate, then allowing the water to sit for 10 minutes and evaporate, thus saturating the chamber. The probe was then calibrated with the Dissolved Oxygen % option, again, using the appropriate atmospheric measurements. This was attempted with both the computer modules we built and the YSI 650-MDS unit.

---

An email was sent to technical support, which generated the following response:

Thanks for contacting our company today. If you have tried to calibrate dissolved oxygen and your are getting the "out of range" error, there are a few things you can check:

-Make sure the sonde and display have the latest firmware (600R sonde is 3.06; 650 display is 1.18). This can be downloaded for free from the ysi.com website. -Remove the old membrane and sand the top of the sensor in one direction. -Rinse and dry the sensor. -Pour DO electrolyte on the top of the sensor and install a new membrane. -Let the sensor warm up for 10-15 minutes and check the readings. -DO Charge should be around 50.0 (+/- 25.0) -Once you feel the readings have stabilized, enter the calibration menu, enter your corrected barometric pressure, and calibrate. -If it calibrates, go into the Advanced menu and look at the Cal Constants. DO Gain should be around 1.000 (+/- 0.250).


If it did not calibrate, DO Charge is out of spec, and/or the DO Gain is out of spec, there is likely another problem. If could be several different things, from the sensor, bulkhead, circuit board, or something else. It would be best to send the system into us at this point. We can provide a free evaluation and contact you by email with a price quote to get the unit back up and running, while meeting factory specs.

Please feel free to contact us if you have additional questions and let us know if you will be sending in the equipment.

Personal tools
Namespaces
Variants
Actions
websites
wiki
this semester
Toolbox